Mac上Ruby和RubyGems安装使用说明

安装 RVM

RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)

    $ curl -L https://get.rvm.io | bash -s stable     

然后,载入 RVM 环境

    $ source ~/.rvm/scripts/rvm

查看当前ruby版本

$ ruby -v  
ruby 1.8.7  
#列出已知的ruby版本  
$ rvm list known  
#安装ruby 1.9.3  
$ rvm install 1.9.3 

步骤3 - 设置 Ruby 版本

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本

    $ rvm 2.0.0 –default
    
    
有可能是因为Ruby的默认源使用的是cocoapods.org,国内访问这个网址有时候会有问题,网上的一种解决方案是将远替换成淘宝的,替换方式如下:

$ gem source -r https://rubygems.org/
$ gem source -a https://ruby.taobao.org

$ gem source -r https://rubygems.org/
https://rubygems.org/ removed from sources
$ gem source -a https://ruby.taobao.org
https://ruby.taobao.org added to sources

要想验证是否替换成功了,可以执行:

$ gem sources -l  
正常的输出结果:
$ gem sources -l
*** CURRENT SOURCES ***
https://ruby.taobao.org

这里就表示已经把Ruby环境成功的安装到了Mac 上了。

ERORR

1,dependency.rb:307:in `to_spec’

First verify ruby is correctly installed:

$ ruby -e 'puts "Testing Ruby"'
From the error, it seems like you haven't installed the rhc gem. First check if it's installed:

$ which rhc
If rhc isn't installed, try this:

$ sudo gem install rhc
$ rhc setup
And try again. 

参考
https://rubygems.org/

梦想还是要有的,万一实现了呢?